Unable to download pictures from Microsoft Teams discussion

teams

Hello everyone,

Today I’ll talk about a misleading feature of Microsoft Teams.

On Teams, you can send and receive documents and pictures in a conversation.

tdf01

 

If you want to keep a copy of the received document, you can easily download it

  • either from the channel itself

tdf02

  • Or from the file when it is in “Edit” mode

tdf03

When you do that, you can see an arrow icon on the “Files” tab on the left of your application.

tdf04

When the download is over, the arrow become an “ok/active/confirm” icon (not sure of the actual name of this icon…)

tdf05

 

That’s cool, ok but only for document and not for pictures.

When you try to interact with a picture, you don’t have the “Download” button.

tdf06

 

If you want to download a picture, you first need to open it and then hit the “Download” button

tdf07bis

And then, nothing happens!

So you hit the button again, and again, and again…

In fact, something did happen, but it was not shown to you. Close the picture and then go to the “Files” tab on the left

tdf08

Then you need to click the “Downloads” link to see your files!

tdf09.png

You will have a file “MicrosoftTeams-image” for each time you clicked the “Download” when the picture was full-screen.

So, you finally have found your pictures even if:

  • Nothing change on the screen when you hit the “Download” on full-screen picture
  • Nothing change on the “Files” tab icon during the download process
  • Nothing was displayed in the default “Recent” section of the “Files” tab

 

Hoping this helps!

Christopher

 

 

Advertisements

SharePoint Designer – Check if item exists

SP2013

Hello everyone,

Today I’ll talk, again, about the SharePoint 2010 Workflows of SharePoint Designer. I know it is deprecated but on some occasion, you need to use what you can!

So, one thing which is missing is the possibility to check if an item exists before doing some action.

For instance, I had an error when I tried to delete item which wasn’t existing. pretty annoying since at the end, what I wanted (not having this file) was done. But my workflow ended in “Error Occurred”.

So, as a workaround, what you can do is create a workflow variable => set its value to a value coming from the item you are looking for => check if the value is not empty to know if the item exists!

spditemexists1

Exactly!

When you try to perform an action on a non-existing item, you end up with a “Error Occurred” but if you want to read a value from a non-existing item, it doesn’t throw any error!

 

Hoping this helps!

Christopher

SharePoint Designer mail format error

SP2013

Hello everyone,

Today I’ll talk about a weird behavior you can have with the SharePoint 2010 Workflows of SharePoint Designer.

The problem was happening with some mail sent. In fact, sometimes, the content of the mail was weird.

Sample:

  • Some text where bold when received by some user
  • Some word where containing spaces coming from nowhere

 

Etc…

After some time checking my mail content, I went to see the properties of the mail

wmc01.png

Then on the body

wmc02

There is the content of my mail

wmc03.png

 

After some check with other mail having no issue, I found that a parameter was missing from the HTML Tag => xmlns:o=”urn:schemas-microsoft-com:office:office”

Change it like this

wmc04.png

Republish and all went ok!

Hoping this helps!

 

Christopher

 

Quick Win – Display template missing

win

Hello everyone,

Today I’ll talk about something that is not quite clear in SharePoint (Yes… again!).

where are my dragons

WHERE ARE MY DRAGONS! …

 

euh, no, where are my Display Templates HTML files??

dtm01

 

When you want to customize a display template, all the “How to” that you can find on the internet mention that you must modify the HTML but not the JavaScript file. Well so…

When you go on a new site for the first time, sometimes those HTML files are not present! As always in SharePoint, when something is missing, let’s take a look at the features we can activate !

dtm02

With everything there, the “Search Server Web Parts and Templates” seams the best choice for me! Let’s add it and it should be ok…

 

dtm01

Well …no..

In fact, we need, again, to activate the Big Gun feature, namely SharePoint Server Publishing Infrastructure!

dtm03

And Voila!

dtm04

 

Really, with all the stuff that this feature provides, I don’t understand why it is not default activated.

 

Hoping this helps!

Christopher