Link in alert mail incorrect

SP2013

Hello everyone,

Today I’ll talk about a problem with standard SharePoint alerts.

It can happen that the links in those emails use inaccessible url by end users, ie the URL of the server. This comes from bad information that can be found everywhere on the net, namely that the url is generated based on the URL used to specify the alert.

After making several tests on a SharePoint to date, I have always had the same urls little import the url used to set the alarm (perhaps a residual bug …)

The result of the tests is that the link used for alert messages is the link specified in the “Default Zone” of “alternate access mapping”.

So just change the order of URLs in AAM to have URL accessible by everyone in the default area.

Hope this helps,

Christopher.

Edit Control Block incomplete

SP2013


Hello everyone,

Today I’ll talk about a problem that may occur in lists and libraries SharePoint 2013.

One of the new SharePoint 2013 feature is the evolution of “Edit Control Block” menu. Now it displays an ellipse for selection. The purpose of this article is not to discuss the artistic choices of this change but to report bugs that may arise.

Once clicked the first ellipse, you see the new “Call-Out Menu” including links to open and share the document and an ellipse which should open following options. Yes .. should ..

Capture

Indeed it may be that when you clicked on this link, instead of displaying the following the menu, nothing happens.

The problem I had is that NOTHING was happening at the click! No JavaScript error, not server error. Nothing at all!

My first thought was of a permissions problem, but tests on several libraries with the same settings had different results! After several tries, I was able to isolate the fact that the problem arose in subfolders of some lists created based on a template. Template itself creates via the SharePoint interface.

Another test was to create a new view with the same parameters, and BINGO it works properly! That means that an error occurred during the creation of the list. After investigation, it turned out that the list was created by PowerShell, perhaps an error has occurred in creation.

The quickest solution to keep your data is to recreate the views for lists with this problem.

Hope this helps,

Christopher.