Alert mail not received

SP2013


Hello everyone,

Today I’ll talk about a problem that may occur when you set alerts for users.

The error in question is the fact that the user receives the mail saying that an alert was created for him, but he is not receiving alerts generated by adding / modifying element.

One reason could be found if you configure the log to “Verbose” for the “Alert” category.

To configure the logs level, follow this procedure:

  • Go to the central administration
  • Click on the “Monitoring
  • In the “Reporting” section, click on the link “Configure diagnostic logging
  • In the “Event throttling” section, just expand the “SharePoint” section and select “Alerts
  • In the dropdown “Least critical event to report to the track log” choose “Verbose
  • Click ok

Note: This operation does not cause recycle or IISRESET, it can be done live on production farm. By cons when you have finished your test, be sure to return to the previous configuration state (choosing “Reset to default” from the dropdown list, failing which your log files grow very large).

 

This configuration will allow you to see such entries

“Alert for Immediate subscription {GUID}, event ID, USERNAME succeeded permissions check”

If instead you see such entries

Alert for Immediate subscription {GUID}, event ID, user USERNAME failed permissions check

You have your culprit!

Indeed, when sending an alert, a test is made in advance to find out whether the user can log in to the site! If you have not yet given access to the user, although it will receive the email telling him that an alert was created for him, he will not receive the actual alerts!

 

Hope this helps,

Christopher.

Advertisements
This entry was posted in SharePoint 2010, SharePoint 2013 and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s