Visual Studio – Unable to connect to team foundation server

VS2012

Hello everyone,

 

Today I’ll talk about an error that I recently had with Visual Studio 2013 and TFS. One day reconnecting me in the morning, I had the strange surprise of not being able to make check-out/check-in in my code!

In my attempts, the “team explorer” window showed me a series of errors such as « System.ComponentModel.Composition.CompositionException: The composition produced a single composition error … »

 

Googling for the error, I did not find the reason for this. Of course I tried the standard resolutions

• Check the rights of my account in TFS

• close and re-open the application

• logoff-login

• reboot

but nothing has changed.

 

To solve this problem I had to delete the cache of Visual Studio! This cache is located in the following directory

C:\Users\{username}\AppData\Local\Microsoft\VisualStudio\12.0\ComponentModelCache

After deleting all the contents (file and folders) and restarted my Visual Studio, everything works properly again.

 

Hope that helps!

 Christopher

Advertisements
This entry was posted in SharePoint 2010 and tagged , . Bookmark the permalink.

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s